// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d{3})(\d{1,3})?(\d{1,3})?(\d{1,2})?$").unwrap();
let string = "011
0112
01121
011212
01121212
0112121234
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}