import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d{3})(\\d{1,3})?(\\d{1,3})?(\\d{1,2})?$";
final String string = "011\n"
+ "0112\n"
+ "01121\n"
+ "011212\n"
+ "01121212\n"
+ "0112121234\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}