package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d{3})(\d{1,3})?(\d{1,3})?(\d{1,2})?$`)
var str = `011
0112
01121
011212
01121212
0112121234
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}