$re = '/^(\d{3})(\d{1,3})?(\d{1,3})?(\d{1,2})?$/m';
$str = '011
0112
01121
011212
01121212
0112121234
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);