#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)The\s*quick\s*brown\s*fox\s*jump(s|a)?\s*over\s*the\s*lazy\s*(cat|dog)"
Local $sString = "The quick brown fox jumpa over the lazy dog" & @CRLF & _
"The quick brown fox jump over the lazy dog" & @CRLF & _
"The quick brown fox jump over the lazy cat" & @CRLF & _
"The quick brown fox jumpa over the lazy cat" & @CRLF & _
"The quickbrownfoxjumpaoverthe lazy cat"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")