using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"The\s*quick\s*brown\s*fox\s*jump(s|a)?\s*over\s*the\s*lazy\s*(cat|dog)";
string input = @"The quick brown fox jumpa over the lazy dog
The quick brown fox jump over the lazy dog
The quick brown fox jump over the lazy cat
The quick brown fox jumpa over the lazy cat
The quickbrownfoxjumpaoverthe lazy cat";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}