$re = '/The\s*quick\s*brown\s*fox\s*jump(s|a)?\s*over\s*the\s*lazy\s*(cat|dog)/i';
$str = 'The quick brown fox jumpa over the lazy dog
The quick brown fox jump over the lazy dog
The quick brown fox jump over the lazy cat
The quick brown fox jumpa over the lazy cat
The quickbrownfoxjumpaoverthe lazy cat';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);