const regex = /The\s*quick\s*brown\s*fox\s*jump(s|a)?\s*over\s*the\s*lazy\s*(cat|dog)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('The\\s*quick\\s*brown\\s*fox\\s*jump(s|a)?\\s*over\\s*the\\s*lazy\\s*(cat|dog)', 'gi')
const str = `The quick brown fox jumpa over the lazy dog
The quick brown fox jump over the lazy dog
The quick brown fox jump over the lazy cat
The quick brown fox jumpa over the lazy cat
The quickbrownfoxjumpaoverthe lazy cat`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}