import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "The\\s*quick\\s*brown\\s*fox\\s*jump(s|a)?\\s*over\\s*the\\s*lazy\\s*(cat|dog)";
final String string = "The quick brown fox jumpa over the lazy dog\n"
+ "The quick brown fox jump over the lazy dog\n"
+ "The quick brown fox jump over the lazy cat\n"
+ "The quick brown fox jumpa over the lazy cat\n"
+ "The quickbrownfoxjumpaoverthe lazy cat";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}