// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)The\s*quick\s*brown\s*fox\s*jump(s|a)?\s*over\s*the\s*lazy\s*(cat|dog)").unwrap();
let string = "The quick brown fox jumpa over the lazy dog
The quick brown fox jump over the lazy dog
The quick brown fox jump over the lazy cat
The quick brown fox jumpa over the lazy cat
The quickbrownfoxjumpaoverthe lazy cat";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}