#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*(\d)\1{5})[6-9]\d{9}$"
Local $sString = "6234567890" & @CRLF & _
"7234567890" & @CRLF & _
"8234567890" & @CRLF & _
"9234567890" & @CRLF & _
"" & @CRLF & _
"1234567890" & @CRLF & _
"9234000000" & @CRLF & _
"0123456789" & @CRLF & _
"92345678900"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")