using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*(\d)\1{5})[6-9]\d{9}$";
string input = @"6234567890
7234567890
8234567890
9234567890
1234567890
9234000000
0123456789
92345678900";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}