$re = '/^(?!.*(\d)\1{5})[6-9]\d{9}$/m';
$str = '6234567890
7234567890
8234567890
9234567890
1234567890
9234000000
0123456789
92345678900';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);