import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*(\\d)\\1{5})[6-9]\\d{9}$";
final String string = "6234567890\n"
+ "7234567890\n"
+ "8234567890\n"
+ "9234567890\n\n"
+ "1234567890\n"
+ "9234000000\n"
+ "0123456789\n"
+ "92345678900";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}