const regex = /^(?!.*(\d)\1{5})[6-9]\d{9}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*(\\d)\\1{5})[6-9]\\d{9}$', 'gm')
const str = `6234567890
7234567890
8234567890
9234567890
1234567890
9234000000
0123456789
92345678900`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}