import re
regex = re.compile(r"^(?!.*(\d)\1{5})[6-9]\d{9}$", flags=re.MULTILINE)
test_str = ("6234567890\n"
"7234567890\n"
"8234567890\n"
"9234567890\n\n"
"1234567890\n"
"9234000000\n"
"0123456789\n"
"92345678900")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")