using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[\s])((?:docstring|some_detailed_notes)\s*=\s*(?://.*\n\s*)*)(((""|\(\s*"")((?:[^""\\]|\\.)+)(""|""\s*\)))*|([\+_a-z ]*)*)(\s*;)";
string input = @"
docstring = ""mystr"";
docstring = ""some \""subs"" + some_str + ""next"";
docstring = (
some_str + ""cde"" + some_str + ""efg"" + another_str + ""ghi""
);
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}