import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[\\s])((?:docstring|some_detailed_notes)\\s*=\\s*(?://.*\\n\\s*)*)(((\"|\\(\\s*\")((?:[^\"\\\\]|\\\\.)+)(\"|\"\\s*\\)))*|([\\+_a-z ]*)*)(\\s*;)";
final String string = "\n"
+ "docstring = \"mystr\";\n\n"
+ "docstring = \"some \\\"subs\" + some_str + \"next\";\n\n"
+ "docstring = (\n"
+ " some_str + \"cde\" + some_str + \"efg\" + another_str + \"ghi\"\n"
+ ");\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}