$re = '/(?<=[\s])((?:docstring|some_detailed_notes)\s*=\s*(?://.*\n\s*)*)((("|\(\s*")((?:[^"\\\\]|\\\\.)+)("|"\s*\)))*|([\+_a-z ]*)*)(\s*;)/';
$str = '
docstring = "mystr";
docstring = "some \\"subs" + some_str + "next";
docstring = (
some_str + "cde" + some_str + "efg" + another_str + "ghi"
);
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);