re = /(?<=[\s])((?:docstring|some_detailed_notes)\s*=\s*(?:\/\/.*\n\s*)*)((("|\(\s*")((?:[^"\\]|\\.)+)("|"\s*\)))*|([\+_a-z ]*)*)(\s*;)/
str = '
docstring = "mystr";
docstring = "some \\"subs" + some_str + "next";
docstring = (
some_str + "cde" + some_str + "efg" + another_str + "ghi"
);
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end