import re
regex = re.compile(r'(?<=[\s])((?:docstring|some_detailed_notes)\s*=\s*(?://.*\n\s*)*)((("|\(\s*")((?:[^"\\]|\\.)+)("|"\s*\)))*|([\+_a-z ]*)*)(\s*;)')
test_str = ("\n"
"docstring = \"mystr\";\n\n"
"docstring = \"some \\\"subs\" + some_str + \"next\";\n\n"
"docstring = (\n"
" some_str + \"cde\" + some_str + \"efg\" + another_str + \"ghi\"\n"
");\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")