const regex = new RegExp('(?<=[\\s])((?:docstring|some_detailed_notes)\\s*=\\s*(?://.*\\n\\s*)*)((("|\\(\\s*")((?:[^"\\\\]|\\\\.)+)("|"\\s*\\)))*|([\\+_a-z ]*)*)(\\s*;)', 'g')
const str = `
docstring = "mystr";
docstring = "some \\"subs" + some_str + "next";
docstring = (
some_str + "cde" + some_str + "efg" + another_str + "ghi"
);
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}