import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!array\\(\\n *)array\\(\\n* *(.*)\\)([,;])*";
final String string = "case 'current_operations':\n"
+ " $array = array(\n"
+ " array('stage_of_development', $this->AB->getTextRep('devstage')),\n"
+ " array('employees', $this->AB->getCompanyProp('employeesnumber')),\n"
+ " array('profitability', $this->AB->getTextRep('profitability'))\n"
+ " );\n"
+ " $icon = 'icon-aim';\n"
+ " break;";
final String subst = "[$1]$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}