use strict;
my $str = 'case \'current_operations\':
$array = array(
array(\'stage_of_development\', $this->AB->getTextRep(\'devstage\')),
array(\'employees\', $this->AB->getCompanyProp(\'employeesnumber\')),
array(\'profitability\', $this->AB->getTextRep(\'profitability\'))
);
$icon = \'icon-aim\';
break;';
my $regex = qr/(?!array\(\n *)array\(\n* *(.*)\)([,;])*/mp;
my $subst = '[$1]$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";