import Foundation
let pattern = #"(?!array\(\n *)array\(\n* *(.*)\)([,;])*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
case 'current_operations':
$array = array(
array('stage_of_development', $this->AB->getTextRep('devstage')),
array('employees', $this->AB->getCompanyProp('employeesnumber')),
array('profitability', $this->AB->getTextRep('profitability'))
);
$icon = 'icon-aim';
break;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[$1]$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)