const regex = /(?!array\(\n *)array\(\n* *(.*)\)([,;])*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!array\\(\\n *)array\\(\\n* *(.*)\\)([,;])*', 'gm')
const str = `case 'current_operations':
\$array = array(
array('stage_of_development', \$this->AB->getTextRep('devstage')),
array('employees', \$this->AB->getCompanyProp('employeesnumber')),
array('profitability', \$this->AB->getTextRep('profitability'))
);
\$icon = 'icon-aim';
break;`;
const subst = `[$1]$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);