import re
regex = re.compile(r"(?!array\(\n *)array\(\n* *(.*)\)([,;])*", flags=re.MULTILINE)
test_str = ("case 'current_operations':\n"
" $array = array(\n"
" array('stage_of_development', $this->AB->getTextRep('devstage')),\n"
" array('employees', $this->AB->getCompanyProp('employeesnumber')),\n"
" array('profitability', $this->AB->getTextRep('profitability'))\n"
" );\n"
" $icon = 'icon-aim';\n"
" break;")
subst = "[$1]$2"
result = regex.sub(subst, test_str)
if result:
print(result)