#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^\d{3,5}$)|(^E\d{3,4}$)|(^V\d{2,4}$)"
Local $sString = "11111" & @CRLF & _
"2222" & @CRLF & _
"999" & @CRLF & _
"E123" & @CRLF & _
"E1234" & @CRLF & _
"V12" & @CRLF & _
"V123" & @CRLF & _
"V1234" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"11" & @CRLF & _
"111111" & @CRLF & _
"11a11" & @CRLF & _
"1a1" & @CRLF & _
"E12" & @CRLF & _
"E12345" & @CRLF & _
"V1" & @CRLF & _
" V123" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")