import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^\\d{3,5}$)|(^E\\d{3,4}$)|(^V\\d{2,4}$)";
final String string = "11111\n"
+ "2222\n"
+ "999\n"
+ "E123\n"
+ "E1234\n"
+ "V12\n"
+ "V123\n"
+ "V1234\n\n\n"
+ "11\n"
+ "111111\n"
+ "11a11\n"
+ "1a1\n"
+ "E12\n"
+ "E12345\n"
+ "V1\n"
+ " V123\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}