# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^\d{3,5}$)|(^E\d{3,4}$)|(^V\d{2,4}$)"
test_str = ("11111\n"
"2222\n"
"999\n"
"E123\n"
"E1234\n"
"V12\n"
"V123\n"
"V1234\n\n\n"
"11\n"
"111111\n"
"11a11\n"
"1a1\n"
"E12\n"
"E12345\n"
"V1\n"
" V123\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.