const regex = /(^\d{3,5}$)|(^E\d{3,4}$)|(^V\d{2,4}$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^\\d{3,5}$)|(^E\\d{3,4}$)|(^V\\d{2,4}$)', 'gm')
const str = `11111
2222
999
E123
E1234
V12
V123
V1234
11
111111
11a11
1a1
E12
E12345
V1
V123
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}