# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[aeiou]/$0+/img;t' <<< "sandwhich
banana
cheese
Ant Eater
"