use strict;
my $str = 'sandwhich
banana
cheese
Ant Eater
';
my $regex = qr/[aeiou]/imp;
my $subst = '$0+';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";