import re
regex = re.compile(r"[aeiou]", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("sandwhich\n"
"banana\n"
"cheese\n"
"Ant Eater\n")
subst = "$0+"
result = regex.sub(subst, test_str)
if result:
print(result)