#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)[aeiou]"
Local $sString = "sandwhich" & @CRLF & _
"banana" & @CRLF & _
"cheese" & @CRLF & _
"Ant Eater" & @CRLF & _
""
Local $sSubst = "$0+"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)