re = /[aeiou]/im
str = 'sandwhich
banana
cheese
Ant Eater
'
subst = '$0+'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result