// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)[aeiou]").unwrap();
let string = "sandwhich
banana
cheese
Ant Eater
";
let substitution = "$0+";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}