using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"23[^.]*c";
string input = @"1a.10.2a.210.22ac.23acd.24acd
1a.10.2a.210.22ac.23axd.24acd
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}