$re = '/23[^.]*c/m';
$str = '1a.10.2a.210.22ac.23acd.24acd
1a.10.2a.210.22ac.23axd.24acd
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);