const regex = /23[^.]*c/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('23[^.]*c', 'gm')
const str = `1a.10.2a.210.22ac.23acd.24acd
1a.10.2a.210.22ac.23axd.24acd
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}