// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)23[^.]*c").unwrap();
let string = "1a.10.2a.210.22ac.23acd.24acd
1a.10.2a.210.22ac.23axd.24acd
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}