re = /23[^.]*c/m
str = '1a.10.2a.210.22ac.23acd.24acd
1a.10.2a.210.22ac.23axd.24acd
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end