import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<left>[^¼½¾\\d]+)*(?<count>¼|½|¾|\\d+\\/\\d+|\\d+)\\s*(?<unit>kilograms|l|cm|m)*(?<right>.*)";
final String string = " left 22/33 kilograms right \n"
+ "Tape 123 Measure\n"
+ "21m Wood Plank\n"
+ " 3l Wood Plank \n"
+ " Wood Plank 20/10 cm \n"
+ " Wood Plank ½ cm \n"
+ "Lawn Mower ¾ cm\n"
+ "Lawn Mower 2/2\n";
final String subst = "$2 $3 $1 $4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}