# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?<left>[^¼½¾\d]+)*(?<count>¼|½|¾|\d+\/\d+|\d+)\s*(?<unit>kilograms|l|cm|m)*(?<right>.*)"
test_str = (" left 22/33 kilograms right \n"
"Tape 123 Measure\n"
"21m Wood Plank\n"
" 3l Wood Plank \n"
" Wood Plank 20/10 cm \n"
" Wood Plank ½ cm \n"
"Lawn Mower ¾ cm\n"
"Lawn Mower 2/2\n")
subst = "$2 $3 $1 $4"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.