use strict;
my $str = ' left 22/33 kilograms right
Tape 123 Measure
21m Wood Plank
3l Wood Plank
Wood Plank 20/10 cm
Wood Plank ½ cm
Lawn Mower ¾ cm
Lawn Mower 2/2
';
my $regex = qr/^(?<left>[^¼½¾\d]+)*(?<count>¼|½|¾|\d+\/\d+|\d+)\s*(?<unit>kilograms|l|cm|m)*(?<right>.*)/mp;
my $subst = '$2 $3 $1 $4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";