$re = '/^(?<left>[^¼½¾\d]+)*(?<count>¼|½|¾|\d+\/\d+|\d+)\s*(?<unit>kilograms|l|cm|m)*(?<right>.*)/m';
$str = ' left 22/33 kilograms right
Tape 123 Measure
21m Wood Plank
3l Wood Plank
Wood Plank 20/10 cm
Wood Plank ½ cm
Lawn Mower ¾ cm
Lawn Mower 2/2
';
$subst = "$2 $3 $1 $4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;