const regex = /^(?<left>[^¼½¾\d]+)*(?<count>¼|½|¾|\d+\/\d+|\d+)\s*(?<unit>kilograms|l|cm|m)*(?<right>.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<left>[^¼½¾\\d]+)*(?<count>¼|½|¾|\\d+\\\/\\d+|\\d+)\\s*(?<unit>kilograms|l|cm|m)*(?<right>.*)', 'gm')
const str = ` left 22/33 kilograms right
Tape 123 Measure
21m Wood Plank
3l Wood Plank
Wood Plank 20/10 cm
Wood Plank ½ cm
Lawn Mower ¾ cm
Lawn Mower 2/2
`;
const subst = `$2 $3 $1 $4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);