import Foundation
let pattern = #"^(?<left>[^¼½¾\d]+)*(?<count>¼|½|¾|\d+\/\d+|\d+)\s*(?<unit>kilograms|l|cm|m)*(?<right>.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
left 22/33 kilograms right
Tape 123 Measure
21m Wood Plank
3l Wood Plank
Wood Plank 20/10 cm
Wood Plank ½ cm
Lawn Mower ¾ cm
Lawn Mower 2/2
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2 $3 $1 $4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)