#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^yellow_y\s+\K\S+"
Local $sString = "yellow abc \" & @CRLF & _
"yellow_x abc \" & @CRLF & _
"yellow_y acc \" & @CRLF & _
"blue abb \" & @CRLF & _
"pink abb \" & @CRLF & _
"pink_xx acd \"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")