import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^yellow_y\\s+\\K\\S+";
final String string = "yellow abc \\\n"
+ "yellow_x abc \\\n"
+ "yellow_y acc \\\n"
+ "blue abb \\\n"
+ "pink abb \\\n"
+ "pink_xx acd \\";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}